Transforming RFC2629-formatted XML through XSLT

RFC2629 through XSLT | J. Reschke
 | greenbytes
 | September 2010

Transforming RFC2629-formatted XML through XSLT

Table of Contents

  • 1. Introduction
  • 2. Supported RFC2629 elements
    • 2.1 Extension elements
  • 3. Processing Instructions
    • 3.1 Supported xml2rfc-compatible PIs
    • 3.2 Unsupported xml2rfc-compatible PIs
    • 3.3 Extension PIs
  • 4. Anchors
  • 5. Supported XSLT engines
    • 5.1 Standalone Engines
    • 5.2 In-Browser Engines
  • 6. Transforming to HTML
    • 6.1 HTML compliance
    • 6.2 Standard HTML LINK elements
    • 6.3 Standard HTML metadata
    • 6.4 Dublin Core (RFC2731) metadata
    • 6.5 Experimental hCard support
  • 7. Transforming to XHTML
  • 8. Transforming to CHM (Microsoft Compiled Help)
  • 9. Transforming to PDF
    • 9.1 Via XSL-FO
      • 9.1.1 Extension feature matrix
      • 9.1.2 Example: producing output for Apache FOP
    • 9.2 Via X(HTML)
  • 10. Generic Extensions
    • 10.1 <abnf-char-sequence> element
    • 10.2 <anchor-alias> element
    • 10.3 <bcp14> element
    • 10.4 <bb> element
    • 10.5 <bc> element
    • 10.6 <blockquote> element
    • 10.7 <boilerplate> element
    • 10.8 <bt> element
    • 10.9 <dfn> element
    • 10.10 <h> element
    • 10.11 <highlight> element
    • 10.12 <length-of> element
    • 10.13 <link> element
    • 10.14 <lt> element
    • 10.15 <note> element
    • 10.16 <parse-xml> element
    • 10.17 <prose> element
    • 10.18 <q> element
    • 10.19 <ref> element
    • 10.20 <source> element
    • 10.21 <sup> element
    • 10.22 Extensions to Xml2rfc <artwork> element
    • 10.23 Extensions to Xml2rfc <iref> element
    • 10.24 Extensions to Xml2rfc <list> element
    • 10.25 Extensions to Xml2rfc <rfc> element
    • 10.26 Extensions to Xml2rfc <section> element
    • 10.27 Extensions to Xml2rfc <xref> element
  • 11. Utilities
    • 11.1 Checking References
    • 11.2 Generating Graphs from References
    • 11.3 Producing reference entries for books
    • 11.4 Down-converting to RFC2629bis DTD
    • 11.5 Extracting artwork
    • 11.6 GRRDL
  • 12. Informative References
  • Author's Address
  • A. RELAX NG Compact Schema
  • B. Implementation Notes
    • B.1 Recognized type attributes for <artwork> element
  • C. Examples
    • C.1 Using the 'Internal Subset'
    • C.2 Customization
  • D. The /rfc/@ipr Attribute
    • D.1 Current Values: '*trust200902'
      • D.1.1 trust200902
      • D.1.2 noModificationTrust200902
      • D.1.3 noDerivativesTrust200902
      • D.1.4 pre5378Trust200902
    • D.2 Historic Values
      • D.2.1 Historic Values: '*trust200811'
      • D.2.2 Historic Values: '*3978'
      • D.2.3 Historic Values: '*3667'
      • D.2.4 Historic Values: '*2026'
  • E. License
  • F. Change Logs
    • F.1 Package
    • F.2 amazon-asin.xslt
    • F.3 check-references.xslt
    • F.4 gen-reference-graph.xslt
    • F.5 rfc2629.xslt
    • F.6 rfc2629toFO.xslt
    • F.7 xsl11toAn.xslt
    • F.8 xsl11toFop.xslt
    • F.9 xsl11toXep.xslt
  • Index

1. Introduction

This document describes a set of XSLT transformations that can be used to transform RFC2629-compliant XML (see [RFC2629]) to various output formats, such as HTML and PDF. The main topics are

  • compliance to the xml2rfc XML element set (Section 2),
  • support for xml2rfc processing instructions (Section 3),
  • the names of anchor elements generated in HTML and PDF output (Section 4),
  • various XSLT engines that can be used (Section 5),
  • outputting HTML (Section 6) and XHTML (Section 7),
  • outputting CHM (Compiled Microsoft Help, Section 8),
  • outputting PDF (Section 9),
  • extensions to the xml2rfc vocabulary (Section 10).
  • various utilities (Section 11).

The full distribution is available at <http://greenbytes.de/tech/webdav/rfc2629xslt.zip>.

2. Supported RFC2629 elements

rfc2629.xslt supports both all RFC2629 grammar elements and the extensions implemented in xml2rfc 1.33.

2.1 Extension elements

rfc2629.xslt supports two kind of extension elements, using different XML namespaces.

The first set contains (hopefully) generally useful extensions, see Section 10.

The second set is used for change and issue tracking and currently is not documented here. Please email the author in case you're interested in using these extensions.

3. Processing Instructions

All PIs can be set as XSLT parameter as well, overriding any value that is found in the source file to be transformed.

Using processing instructions:

<?rfc toc="yes"?>
<?rfc-ext support-rfc2731="no"?>

Using XSLT parameters (Saxon):

java -cp saxon.jar com.icl.saxon.StyleSheet source.xml rfc2629.xslt \
  xml2rfc-toc=yes xml2rfc-ext-support-rfc2731=no > result.html

Using XSLT parameters (xsltproc):

xsltproc --param xml2rfc-toc '"yes"' \
   --param xml2rfc-ext-support-rfc2731 '"no"' \
   rfc2629.xslt source.xml > result.html

(note the required quoting of string parameters)

3.1 Supported xml2rfc-compatible PIs

PI target | PI pseudo-attribute | XSLT parameter name | default | comment
rfc | background | xml2rfc-background | (not set) |
rfc | compact | xml2rfc-compact | "no" | only applies to HTML output method when printing
rfc | comments | xml2rfc-comments | (not set) |
rfc | editing | xml2rfc-editing | "no" |
rfc | footer | xml2rfc-footer | (not set) |
rfc | header | xml2rfc-header | (not set) |
rfc | inline | xml2rfc-inline | (not set) |
rfc | iprnotified | xml2rfc-iprnotified | "no" |
rfc | linkmailto | xml2rfc-linkmailto | "yes" |
rfc | private | xml2rfc-private | (not set) |
rfc | refparent | xml2rfc-private | "References" | Title for References sections when automatically inserted
rfc | rfcedstyle | xml2rfc-rfcedstyle | (not set) | (limited support)
rfc | sortrefs | xml2rfc-sortrefs | "no" |
rfc | symrefs | xml2rfc-symrefs | "yes" | The default has changed from "no" to "yes" as of June 6, 2007 and xml2rfc 1.33pre4.
rfc | toc | xml2rfc-toc | "no" |
rfc | tocdepth | xml2rfc-tocdepth | 99 |
rfc | topblock | xml2rfc-topblock | "yes" |

3.2 Unsupported xml2rfc-compatible PIs

PI target | PI pseudo-attribute | comment
rfc | include | incompatible with XML/XSLT processing model, please use external entities instead
rfc | needLines |
rfc | slides |
rfc | strict |
rfc | subcompact |
rfc | tocindent | (defaults to "yes")
rfc | tocompact |

3.3 Extension PIs

PI target | PI pseudo-attribute | XSLT parameter name | default | description
rfc-ext | allow-markup-in-artwork | xml2rfc-allow-markup-in-artwork | "no" | Enables support for specific elements inside abstract elements (using this extension makes the document incompatible to the RFC2629bis DTD; see description of conversion XSLT in Section 11.4).
rfc-ext | authors-section | xml2rfc-ext-authors-section |  | When "end", place the authors section at the end (just before the copyright statements). This seems to be the preferred order in the newest RFCs.
rfc-ext | duplex | xml2rfc-ext-duplex | no | When set to "yes", format the PDF output for doublesided printing.
rfc-ext | include-references-in-index | xml2rfc-ext-include-references-in-index |  | When set to "yes", index entries are generated for all references.
rfc-ext | justification | xml2rfc-ext-justification | "never" | "never": never emit justified text, "always": always emit justified text, "print": only emit justified text for print media.
rfc-ext | parse-xml-in-artwork | xml2rfc-parse-xml-in-artwork | "no" | May be used to enable parsing of XML content in figures (MSXML only).
rfc-ext | support-rfc2731 | xml2rfc-ext-support-rfc2731 | "yes" | Decides whether the HTML transformation should generate META tags according Section 6.4.
rfc-ext | sec-no-trailing-dots | xml2rfc-ext-sec-no-trailing-dots |  | When set to "yes", add trailing dots to section numbers. This seems to be the preferred format in the newest RFCs.

4. Anchors

The transformation automatically generates anchors that are supposed to be stable and predictable and that can be used to identify specific parts of the document. Anchors are generated both in HTML and XSL-FO content (but the latter will only be used for PDF output when the XSL-FO engine supports producing PDF anchors).

The following anchors get auto-generated:

Anchor name | Description
rfc.abstract | Abstract
rfc.authors | Authors section
rfc.copyright | Copyright section
rfc.copyrightnotice | Copyright notice
rfc.figure.n | Figures (titled)
rfc.figure.u.n | Figures (untitled)
rfc.index | Index
rfc.ipr | Intellectual Property
rfc.iref.n | Internal references
rfc.note.n | Notes (from front section)
rfc.references | References
rfc.references.n | Additional references
rfc.section.n | Section n
rfc.section.n.p.m | Section n, paragraph m
rfc.status | Status of memo
rfc.table.n | Tables (titled)
rfc.table.u.n | Tables (untitled)
rfc.toc | Table of contents
rfc.xref.name.n | References to reference n to name

5. Supported XSLT engines

The transformation requires a non-standard extension function (see exsl:node-set) which is however widely available. XSLT processors that do not support this extension (or a functional equivalent) currently are not supported.

5.1 Standalone Engines

The following XSLT engines are believed to work well:

  • Windows: MSXML3 and MSXML4 (<http://msdn.microsoft.com/xml>; command line processor "msxsl" is available from Microsoft Download Center)
  • Java: Saxon (<http://saxon.sourceforge.net/>)
  • Java: Xalan (<http://xml.apache.org/xalan-j/>)
  • C/C++: xsltproc (libxslt) (<http://xmlsoft.org/XSLT/>, make sure that you have a current version)

5.2 In-Browser Engines

The following browsers seem to work fine:

  • Internet Explorer 5.5 (Windows version, if MSXML3 is installed)

  • Internet Explorer 6 and newer

  • Firefox 3.0 and newer

    • Be aware that XSLT execution can be suppressed using NoScript
    • Firefox does not load external DTDs nor external entities, see Mozilla Bug 22942, thus entities like &nbsp; need to be declared in the internal subset (Appendix C.1)

  • Safari 3 (starting with version 3.0.4)

  • Google Chrome

  • Opera (starting with version 10)

The following browsers are known not to work properly:

  • Firefox 1.*/2.*: (missing extension function - see change request at Mozilla BugZilla 193678)

  • Opera 9.21: execution fails, potentially to a somewhat complex XPath expression (reported to Opera as bug 245725).

  • Opera 9.5 and 9.6: transformation appears to work, but CSS isn't getting applied (reported to Opera as bug 337388 on 2008-06-12).

  • Safari 2.* supports client-side XSLT as of MacOS X 10.4, but misses required extension functions. A problem with stylesheets producing non-ASCII output (such as NBSP characters) has been fixed as of OSX 10.4.4. Both problems have been reported through Apple's bug tracking system, see <http://drakken.dbc.mtview.ca.us/pipermail/xml2rfc/2005-May/002073.html> and <http://bugs.webkit.org/show_bug.cgi?id=4079>.

6. Transforming to HTML

Transformation to HTML can be done inside the browser if it supports XSLT. To enable this, add the following processing instruction to the start of the source file:

  <?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>

(and ensure that rfc2629.xslt is present).

6.1 HTML compliance

The transformation result is supposed to conform to the HTML 4.01 strict DTD [HTML]. This can be checked using the W3C's online validator at <http://validator.w3.org>.

6.2 Standard HTML LINK elements

LINK elements exist since HTML 2.0. They can be used to embed content-independant links inside the document. Unfortunately, only few user agents support this element. Firefox users may want to check the Link Widgets extension.

The following LINK elements are produced:

LINK type | description
alternate | for RFCs, a link to the authorative ASCII version on the IETF web site
appendic | pointer to all top-level appendics
author | pointer to "authors" section
chapter | pointer to all top-level sections
contents | pointer to table of contents
copyright | pointer to copyright statement
index | pointer to index

The figure below shows how Mozilla Firefox 1.0 displays the Site Navigation Bar for rfc2396.xml.

(LINK elements displayed in Mozilla Firefox for RFC2396.xml)

6.3 Standard HTML metadata

The following standard HTML META elements are produced:

META name | description
generator | from XSLT engine version and stylesheet version
keywords | from keyword elements in front section

6.4 Dublin Core (RFC2731) metadata

Unless turned off using the "rfc-ext support-rfc2731" processing instruction, the transformation will generate metadata according to [RFC2731] and [DC-HTML].

The following DCMI properties are produced:

META name | description
DC.Creator | from author information in front section
DC.Date.Issued | from date information in front section
DC.Description.Abstract | from abstract
DC.Identifier | document URN [RFC2648] from "docName" attribute
DC.isPartOf | RFC ISSN (for RFCs)
DC.Relation.Replaces | from "obsoletes" attribute

6.5 Experimental hCard support

The generated author information is formatted in hCard format.

7. Transforming to XHTML

Transforming to XHTML requires slightly different XSLT output options and is implemented by the derived transformation script rfc2629toXHTML.xslt.

  • Note: Microsoft Internet Explorer does not support XHTML. Therefore it usually makes more sense to generate plain old HTML.

8. Transforming to CHM (Microsoft Compiled Help)

To generate a CHM file using Microsoft's HTML Help Compiler (hhc), three files are required in addition to the HTML file.

  1. hhc - table of contents file (HTML)
  2. hhk - index file (HTML)
  3. hhp - project file (plain text)

The three files are generated with three specific transformations, each requiring the additional XSLT parameter "basename" to specify the filename prefix.

Example:

saxon rfc2616.xml rfc2629toHhp.xslt basename=rfc2616  > rfc2616.hhp
saxon rfc2616.xml rfc2629toHhc.xslt basename=rfc2616  > rfc2616.hhc
saxon rfc2616.xml rfc2629toHhk.xslt basename=rfc2616  > rfc2616.hhk
hhc rfc2616.hhp

9. Transforming to PDF

9.1 Via XSL-FO

Transformation to XSL-FO [XSL-FO] format is available through rfc2629toFO.xslt (which includes rfc2629.xslt, so keep both in the same folder).

Compared to HTML user agents, XSL-FO engines unfortunately either come as open source (for instance, Apache FOP) or feature-complete (for instance, AntennaHouse XSL Formatter), but not both at the same time.

As Apache FOP needs special workarounds (index generation), and some popular extensions aren't standardized yet, the translation produces a generic output (hopefully) conforming to [XSL-FO]. Specific backends (xsl11toFop.xslt, xsl11toXep.xslt, xsl11toAn.xslt) then provide post-processing for the individual processors.

Note: the output is currently targeted at Apache FOP 1.0.

9.1.1 Extension feature matrix

 | PDF anchors | PDF bookmarks | PDF document information | Index cleanup
XSL 1.1 WD | no, but can be auto-generated from "id" attributes | yes | no, but uses XEP output extensions | yes
Antenna House XSL formatter | no | yes (from XSL 1.1 bookmarks) | yes (from XEP document info) | yes (just page duplicate elimination, from XSL 1.1 page index)
Apache FOP | yes | yes (from XSL 1.1 bookmarks) | yes | no
RenderX XEP | no | yes (from XSL 1.1 bookmarks) | yes | yes (from XSL 1.1 page index)

9.1.2 Example: producing output for Apache FOP

Example:

saxon rfc2616.xml rfc2629toFo.xslt > tmp.fo
saxon tmp.fo xsl11toFop.xslt > rfc2629.fo

9.2 Via X(HTML)

PDF output can also be produced directly from (X)HTML. One simple approach is to rely on the browser's printing function, and to use a printer driver that produces PDF. Depending on the brower's CSS capabilities, the output will behave properly with respect to table breaks etc.

An alternative is PrinceXML (see <http://www.princexml.com/>), which can produce PDF directly from (X)HTML input, based on the CSS printing information.

For instance, PDF output with text justification turned on can be produced with:

saxon input.xml rfc2629toXHTML.xslt xml2rfc-ext-justification=print \
  > output.xhtml
prince output.xhtml output.pdf

10. Generic Extensions

This section documents extensions implemented in rfc2629.xslt, using the extension namespace "http://purl.org/net/xml2rfc/ext".

10.1 <abnf-char-sequence> element

Converts the contained quoted string into a hex-encoded character sequence, for use in case-sensitive ABNF productions.

For instance, "<x:abnf-char-sequence>"HTTP"</x:abnf-char-sequence>" gets converted to "%x48.54.54.50".

10.2 <anchor-alias> element

Using its "value" attribute, this element allows the definition of an internal link target alias for the enclosing element. This alias can then be used with the <ref> element for intra-document references.

Note that the anchor alias is not subject to the naming constraints that apply to anchor elements (which are XML names).

10.3 <bcp14> element

This element marks the content as being one of the normative keywords defined in [RFC2119].

The DOCTYPE definition below allows using these keywords using XML entity expansion: such as in "...server &MUST; accept...".

<!DOCTYPE rfc [
 <!ENTITY MAY "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'
   >MAY</bcp14>">
 <!ENTITY MUST "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'
   >MUST</bcp14>">
 <!ENTITY MUST-NOT "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'
   >MUST NOT</bcp14>">
 <!ENTITY OPTIONAL "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'
   >OPTIONAL</bcp14>">
 <!ENTITY RECOMMENDED "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'
   >RECOMMENDED</bcp14>">
 <!ENTITY REQUIRED "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'
   >REQUIRED</bcp14>">
 <!ENTITY SHALL "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'
   >SHALL</bcp14>">
 <!ENTITY SHALL-NOT "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'
   >SHALL NOT</bcp14>">
 <!ENTITY SHOULD "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'
   >SHOULD</bcp14>">
 <!ENTITY SHOULD-NOT "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'
   >SHOULD NOT</bcp14>">]>

10.4 <bb> element

Marking up a string as <bb> indicates that it represents the bottom line of a box drawing, replacing the "+" and "-" characters accordingly.

10.5 <bc> element

Marking up a string as <bc> indicates that it represents a center line of a box drawing, replacing the "|" character accordingly.

10.6 <blockquote> element

This element is like the "blockquote" element in [HTML] (note this is a block-level element!). It should contain one or more <t> child elements.

10.7 <boilerplate> element

Can be used to include boilerplate (status, copyright, ...) into the front or back section. <section> elements within <x:boilerplate> appear as unnumbered sections in the output.

This element currently can not be "down-translated" for use in xml2rfc!

10.8 <bt> element

Marking up a string as <bt> indicates that it represents the top line of a box drawing, replacing the "+" and "-" characters accordingly.

10.9 <dfn> element

This element is like the "dfn" element in [HTML].

10.10 <h> element

This element is like the "h" element in [XHTML2].

10.11 <highlight> element

Used to highlight text passages, currently only allowed in <artwork>.

Note: this is stripped when generating input for xml2rfc, so please use with care.

10.12 <length-of> element

This element can be used to insert the length of another formatted section (in decimal).

Example: computing the Content-Length header value

<artwork>
...
Content-Length: <x:length-of target="req"/>

<x:span anchor="req">123456789
<x:span><artwork/>

The lenght computation counts line ends as two characters (CRLF).

Note that indentation characters in artwork will be counted. The "indented" attribute allows to specify the amount of indentation to be substracted from the computed length.

10.13 <link> element

This element can be added as a top-level child element below <rfc> to indicate additional link information. It's currently used only when generating HTML output, in which case an HTML <link> element with identical attributes gets generated.

Example: generating HTML link element

        <x:link xmlns="http://purl.org/net/xml2rfc/ext"
            rel="Bookmark"
            title="IETF WEBDAV Working Group"
            href="http://ftp.ics.uci.edu/pub/ietf/webdav/"/>

10.14 <lt> element

Used for grouping multiple <t> elements into a single list item.

10.15 <note> element

Can be used to add a note, usually indented by a few characters. It should contain one or more <t> child elements.

10.16 <parse-xml> element

This element instructs the processor to parse the contents as XML and to warn when there's a problem (requires either MSXML or Saxon8 or newer).

10.17 <prose> element

This element can be used inside <reference> to add plain text (before the date, when present).

10.18 <q> element

This element is like the "q" element in [HTML].

10.19 <ref> element

This element is a simplified variant of the <xref> element, in that no "target" attribute needs to be specified, instead the text contents acts as identifier. That in itself wouldn't be terribly useful, but together with the <anchor-alias>, it allows referring to other parts of the document with minimal additional markup.

For instance, given an alias definition such as

      <section title="Test" anchor="test">
        <x:anchor-alias value="alias1"/>
        <x:anchor-alias value="alias 2"/>
        ...
      </section>

the following simple references

      <x:ref>test</x:ref>
      <x:ref>alias1</x:ref>
      <x:ref>alias 2</x:ref>

are equivalent to...:

      <xref target="test">test</xref>
      <xref target="test">alias1</xref>
      <xref target="test">alias 2</xref>

10.20 <source> element

Can be used to enhance a <reference> with information about the location for the XML source. This can be used by the <xref> processing code to automatically extract the target section number.

For example:

      ...
      <xref target="RFC2616" x:fmt="of" x:rel="#PUT" />
      ...

      <reference target="RFC2616"/>
        ...
        <x:source href="rfc2616.xml"/>
        ...

10.21 <sup> element

This element is like the "sup" element in [HTML].

Note: the down conversion to RFC2629 format replaces "xy" by "x^y".

10.22 Extensions to Xml2rfc <artwork> element

Sometimes, artwork occurs inside lists. To get it indent properly in xml2rfc's text output, it needs to be indented in the source. This is sub-optimal, as this whitespace will also appear in the HTML output, where it's already indented due to HTML's semantics.

As a workaround, a "x:indent-with" attribute can be specified, containing a string that will be prepended to each line when clean-for-DTD.xslt is run (see Section 11.4).

10.23 Extensions to Xml2rfc <iref> element

The extension attribute below is allowed on the standard <iref> element:

  • x:for-anchor specifies that the <iref> will also be automatically inserted whenever the specified anchor is cross-referenced -- this may save entering lots of <iref> instances. As a special case, a value of "" (empty string) refers to the anchor attribute of the closest ancestor.

10.24 Extensions to Xml2rfc <list> element

The extension attribute below is allowed on the standard <list> element:

  • x:indent specifies the amount of indentation for list items in hanging lists. This can be useful when the output format, such as XSL-FO, does not support automatical formatting. The value takes an XSL-FO width, such as "5em". The default is length of longest label in characters times 0.8em.

Also, the <list> element can take <x:lt> child elements instead of <t>, allowing to insert multiple paragraphs into a single list item.

10.25 Extensions to Xml2rfc <rfc> element

The extension attributes below are allowed on the standard <rfc> element:

  • grddl:transformation can be used to reference a GRDDL transform.
  • x:maturiy-level can be used to specify the IETF Standards Track Maturity Level of "proposed", "draft" or "internet" (see Section 4.1 of [RFC2026]).

10.26 Extensions to Xml2rfc <section> element

The extension attribute below is allowed on the standard <list> element:

  • x:fixed-section-number can be used to specify a fixed section number. This can be useful when formatting historic documents that used a different numbering style.

10.27 Extensions to Xml2rfc <xref> element

Three extension attributes are allowed on the standard <xref> element:

  1. x:sec can be specified to point to a specific section of the referenced document,
  2. x:rel may specify a relative reference to use when linking into the referenced document (if linking by section number is not available),
  3. x:fmt defines the text format to be used.

The following formats are defined for the x:fmt attribute:

, (Comma)
[reference], Section sec
()
[reference] (Section sec)
anchor
Like the default format, but without brackets.
of
Section sec of [reference]
number
sec
none
No output (can be used to have xrefs to references without having them rendered as such)
sec
Section sec

These extensions are currently only supported for <xref> elements without child nodes.

If the processor knows how to reference the target section, it will generate a link directly to the target section, such as in [RFC2119], Section 5.

11. Utilities

11.1 Checking References

check-references.xslt can be used to check all references to RFC- and ID-series IETF publications and to W3C publications (note this script requires local copies of <ftp://ftp.isi.edu/in-notes/rfc-index.xml> and <http://www.w3.org/2002/01/tr-automation/tr.rdf> and will use the XML status information provided at <http://tools.ietf.org/>).

If the document is supposed to be published on the IETF standards track, the desired level can be specified using the parameter intended-level as 'proposed', 'draft' or 'internet'. Alternatively, it can be specified inside the document using the attribute x:maturity-level on the <rfc> element.

Note: Downward references should be annotated using the <annotate> element, containing an <xref> to [BCP97].

When an XSLT 2.0 processor is used, links in the document can be checked as well using the link-check paramerer ('yes' or 'no'). Note that this only works for http links to documents of type text/*.

For instance, as of 2008-07-12, the script produces for <http://greenbytes.de/tech/webdav/rfc2518.xml>:

> saxon rfc2518.xml check-references.xslt intended-status=PROPOSED \
  link-check=yes

Normative References:
ISO-11578: not checked
ISO-639: not checked
ISO-8601: not checked
REC-xml-19980210: [FirstEdition] obsoleted by REC-xml-20001006
REC-xml-names-19990114: [FirstEdition] obsoleted by
 REC-xml-names-20060816
RFC1766: [PROPOSED STANDARD] obsoleted by RFC3066 RFC3282
RFC2068: [PROPOSED STANDARD] obsoleted by RFC2616
RFC2069: [PROPOSED STANDARD] obsoleted by RFC2617
RFC2119: [BEST CURRENT PRACTICE] (-> BCP0014) ok
RFC2141: [PROPOSED STANDARD] ok
RFC2277: [BEST CURRENT PRACTICE] (-> BCP0018) ok
RFC2396: [DRAFT STANDARD] obsoleted by RFC3986
RFC2279: [DRAFT STANDARD] obsoleted by RFC3629

Informational References:
REC-PICS-labels-961031: [REC] ok
RFC1807: [INFORMATIONAL] ok
RFC2026: [BEST CURRENT PRACTICE] (-> BCP0009) ok
RFC2291: [INFORMATIONAL] ok
RFC2376: [INFORMATIONAL] obsoleted by RFC3023
RFC2413: [INFORMATIONAL] obsoleted by RFC5013
USMARC: not checked
WF: not checked

Link Targets
<http://www.w3.org/TR/1998/REC-xml-19980210>: ok
<http://www.w3.org/TR/1999/REC-xml-names-19990114>: ok
<http://www.dlib.org/dlib/july96/lagoze/07lagoze.html>: ok
<http://www.w3.org/pub/WWW/TR/REC-PICS-labels-961031.html>: ok

Recognized formats in the <seriesInfo> element are:

  • for RFCs, the name attribute must be "RFC", and the value attribute must be the number of the RFC,
  • for Internet Drafs, the name attribute must be "ID" or "Internet-Draft", and the value attribute must be the file name of the draft (including the two-digit running number, but excluding a file extension),
  • for W3C documents, the name attribute must be "W3C", must start with "W3C ", or must start with "World Wide Web Consortium ", and the value attribute must be the "shorthand" name of the specification, such as "REC-xml-19980210".

Note: this stylesheet will need network access to check links and status of Internet Drafts. When running a Java-based XSLT engine, you may have to supply Java system properties specifying the HTTP proxy to be used, such as "-Dhttp.proxyHost=hostname -Dhttp.proxyPort=80".

11.2 Generating Graphs from References

gen-reference-graph.xslt generates a graph of RFC dependencies, using the same base data as in check-references.xslt (see Section 11.1). Its output is a "dot" file, to be processed by GraphViz (see <http://www.graphviz.org/>).

The picture below shows the RFC dependencies in RFC2629.

(PNG output obtained from GraphViz)

11.3 Producing reference entries for books

amazon-asin.xslt uses the Amazon web services to generate a <reference> element for a given ASIN (ISBN).

For instance:

<?xml version="1.0" encoding="utf-8"?>
<references>
 <reference target="urn:isbn:0134516591">
   <front>
     <title>Simple Book, The: An Introduction to Internet Management,
               Revised Second Edition</title>
     <author surname="Rose"
                fullname="Marshall T. Rose" initials="M. T. ">
       <organization/>
     </author>
     <author surname="Marshall"
                fullname="Rose T. Marshall" initials="R. T.">
       <organization/>
     </author>
     <date year="1996" month="March"/>
   </front>
   <seriesInfo name="Prentice Hall" value=""/>
 </reference>
</references>

Note that the resulting XML usually requires checking, in this case Amazon's database is playing tricks with Marshall's name...

11.4 Down-converting to RFC2629bis DTD

clean-for-DTD.xslt can be used to down-convert some extensions to a format that is supported by the base xml2rfc distribution. Note that these extensions are experimental (feedback appreciated).

The following mappings are done:

  • <iref> elements inside <artwork> elements are moved in front of the enclosing <figure> element.
  • <xref> elements inside <artwork> are expanded just like in regular text (that is, the markup is stripped, but the element is replaced by the applicable replacement text).
  • <x:anchor-alias> elements get stripped.
  • <x:bcp14> elements get stripped.
  • <x:bb>, <x:bc> and <x:bt> elements get stripped.
  • <x:blockquote> elements get converted to indented text (through a <list> element).
  • <x:dfn> elements get stripped.
  • <x:h> elements get stripped.
  • <x:link> elements get stripped.
  • <x:note> elements get converted to indented text (through a <list> element).
  • <x:q> elements get stripped, with apostrophes added around the text.
  • <x:prose> elements are transformed into <seriesInfo> elements (which is an abuse of the element and only a workaround until xml2rfc gets a matching extension).
  • <x:ref> elements get replaced by <xref> elements, targetting either the anchor or another anchor with matching <x:anchor-alias> child element.

11.5 Extracting artwork

With extract-artwork.xslt, artwork elements named through the "name" attribute can be extracted. This can be used to automatically check their syntax (for instance, when ABNFs appear within a figure element).

For instance:

saxon rfc3986.xml extract-artwork.xslt name=uri.abnf

In addition, artwork of a specific type can be extracted, such as with:

saxon rfc3986.xml extract-artwork.xslt type=abnf

When extracting by type, artwork elements with a specified name can be excluded; this can be handy when the document uses some kind of schema language, and an appendix contains the collected schema, repeating definitions from earlier on. Example:

saxon rfc3986.xml extract-artwork.xslt type=abnf except-name=clschm

11.6 GRRDL

rfc2629grddl.xslt extracts RDF information. This is experimental work-in-progress. See <http://www.w3.org/TR/grddl/> for more information.

12. Informative References

[BCP97] | Klensin, J. and S. Hartman, “Handling Normative References to Standards-Track Documents”, BCP 97, RFC 4897, June 2007.
[DC-HTML] | Johnston, P. and A. Powell, “Expressing Dublin Core metadata using HTML/XHTML meta and link elements”, Dublin Core Metadata Initiative, August 2008, <http://dublincore.org/documents/2008/08/04/dc-html/>.
[HTML] | Raggett, D., Hors, A., and I. Jacobs, “HTML 4.01 Specification”, W3C REC-html401-19991224, December 1999, <http://www.w3.org/TR/html401/>.
[RFC2026] | Bradner, S., “The Internet Standards Process -- Revision 3”, BCP 9, RFC 2026, October 1996.
[RFC2119] | Bradner, S., “Key words for use in RFCs to Indicate Requirement Levels”, BCP 14, RFC 2119, March 1997.
[RFC2616] | Fielding, R., Gettys, J., Mogul, J., Nielsen, H., Masinter, L., Leach, P., and T. Berners-Lee, “Hypertext Transfer Protocol -- HTTP/1.1”, RFC 2616, June 1999.
[RFC2629] | Rose, M., “Writing I-Ds and RFCs using XML”, RFC 2629, June 1999.
[RFC2648] | Moats, R., “A URN Namespace for IETF Documents”, RFC 2648, August 1999.
[RFC2731] | Kunze, J., “Encoding Dublin Core Metadata in HTML”, RFC 2731, December 1999.
[RFC5234] | Crocker, D., Ed. and P. Overell, “Augmented BNF for Syntax Specifications: ABNF”, STD 68, RFC 5234, January 2008.
[RNC] | Clark, J., “RELAX NG Compact Syntax”, OASIS, Nov 2002, <http://www.oasis-open.org/committees/relax-ng/compact-20021121.html>.
[XHTML2] | Axelsson, J., Birbeck, M., Dubinko, M., Epperson, B., Ishikawa, M., McCarron, S., Navarro, A., and S. Pemberton, “XHTML™ 2.0”, W3C WD-xhtml2-20060726, July 2006, <http://www.w3.org/TR/xhtml2>.
[XML] | Bray, T., Paoli, J., Sperberg-McQueen, C., Maler, E., and F. Yergeau, “Extensible Markup Language (XML) 1.0 (Fifth Edition)”, W3C REC-xml-20081126, November 2008, <http://www.w3.org/TR/2008/REC-xml-20081126/>.
[XSL-FO] | Berglund, A., “Extensible Stylesheet Language (XSL) Version 1.1”, W3C REC-xsl11-20061205, Dec 2006, <http://www.w3.org/TR/2006/REC-xsl11-20061205/>.

Author's Address

Julian F. ReschkeReschkeJulian F.greenbytes GmbHHafenweg 16Muenster, NW 48155GermanyPhone: +49 251 2807760EMail: julian.reschke@greenbytes.deURI: http://greenbytes.de/tech/webdav/

A. RELAX NG Compact Schema

The RelaxNG schema ([RNC]) below can be used to validate input documents (for instance, with Jing).

Note that this is work in progress, and doesn't yet cover all extensions completely.

# WORK IN PROGRESS! PLEASE REPORT PROBLEMS TO THE AUTHOR.

# Define our extension namespace
namespace x = "http://purl.org/net/xml2rfc/ext"

# Define GRDDL namespace
namespace grddl = "http://www.w3.org/2003/g/data-view#"

# Define RDF namespace
namespace rdf = "http://www.w3.org/1999/02/22-rdf-syntax-ns#"

# Include rfc2629bis RNC grammar
include "rfc2629.rnc" {

  # Redefine <artwork> to allow markup
  artwork =
    element artwork {
      attlist.artwork,
      (TEXT
        | eref
        | iref
        | spanx
        | xref
        | x_abnf-char-sequence
        | x_bb
        | x_bc
        | x_bcp14
        | x_bt
        | x_highlight
        | x_length-of
        | x_parse-xml
        | x_ref
        | x_span
        | x_x)*
    }

  # Redefine <back> to allow boilerplate
  back =
    element back {
      attlist.back,
      references*,
      section*,
      x_boilerplate?
    }

  # Redefine <c> to allow our extension elements
  c =
    element c {
      attlist.c,
      (TEXT
        | xref
        | eref
        | iref
        | cref
        | spanx
        | x_ref)*
    }

  # Redefine <cref> to allow more child elements
  cref =
    element cref {
      attlist.cref,
      (TEXT
        | eref
        | xref)*
    }

  # Redefine <front> to allow boilerplate
  front =
    element front {
      attlist.front,
      title,
      author+,
      date,
      area*,
      workgroup*,
      keyword*,
      x_boilerplate?,
      abstract?,
      note*
    }

  # Redefine <list> element to allow <x:lt> child elements
  \list =
    element list {
      attlist.list,
      (t+ | x_lt+)
    }

  # Redefine <preamble> to allow our extension elements
  preamble =
    element preamble {
      attlist.preamble,
      (TEXT
        | xref
        | eref
        | iref
        | cref
        | spanx
        | x_anchor-alias)*
    }

  # Redefine <postamble> to allow our extension elements
  postamble =
    element postamble {
      attlist.postamble,
      (TEXT
        | xref
        | eref
        | iref
        | cref
        | spanx
        | x_bcp14)*
    }

  # Redefine <reference> to allow our extension elements
  reference =
    element reference {
      attlist.reference,
      front,
      seriesInfo*,
      x_prose?
      format*,
      annotation*,
      x_source?
    }

  # Redefine <rfc> to allow our extension elements
  rfc =
    element rfc {
      attlist.rfc,
      x_link*,
      x_assign-section-number*,
      front,
      middle,
      back?
    }

  # Redefine <section> to allow our extension elements
  section =
    element section {
      attlist.section,
      (t
       | figure
       | texttable
       | iref
       | section
       | x_anchor-alias
       | x_blockquote
       | x_include-author
       | x_note
       | rdf_Description)*
    }

  # Redefine <spanx> to allow some markup
  spanx =
    element spanx {
      attlist.spanx,
      (TEXT
        | iref
        | xref
        | x_ref)*
    }

  # Redefine <t> to allow our extension elements
  t =
    element t {
      attlist.t,
      (TEXT
       | \list
       | figure
       | xref
       | eref
       | iref
       | cref
       | spanx
       | vspace
       | x_abnf-char-sequence
       | x_anchor-alias
       | x_bcp14
       | x_dfn
       | x_h
       | x_q
       | x_ref
       | x_sup)*
    }
}

# Allow x:indent-with attribute on <artwork>
attlist.artwork &=
  attribute x:indent-with { ATEXT }?

# Allow anchor and x:annotation attributes on <author>
attlist.author &=
  attribute anchor { xsd:ID }?,
  attribute x:annotation { ATEXT }?

  # Extend attribute set for <iref> (see Section 10.23)
attlist.iref &=
  attribute x:for-anchor { ATEXT }?

# Extend attribute set for <list> (see Section 10.24)
attlist.list &=
  attribute x:indent { ATEXT }?

# Extend attribute set for <preamble>
attlist.preamble &=
  attribute anchor { xsd:ID }?

# Extend attribute set for <rfc>
attlist.rfc &=
  attribute grddl:transformation { ATEXT }?,
  attribute x:maturity-level { "proposed" | "draft" | "internet" }?

# Extend attribute set for <section> (see Section 10.26)
attlist.section &=
  attribute x:fixed-section-number { ATEXT }?

# Allow anchor attribute on <spanx>
attlist.spanx &=
  attribute anchor { xsd:ID }?

# Allow x:quotes attribute on <title>
attlist.title &=
  attribute x:quotes { "true" | "false" }?

# Allow annotation attribute on <uri>
attlist.uri &=
  attribute x:annotation { ATEXT }?

# Extend attribute set for <xref> (see Section 10.27)
attlist.xref &=
  attribute x:fmt  { "()" | "," | "anchor" | "of" | "number" | "sec" |
                     "none" }?,
  attribute x:rel  { ATEXT }?,
  attribute x:sec  { ATEXT }?

# Conversion to ABNF char sequence (see Section 10.1)
x_abnf-char-sequence =
  element x:abnf-char-sequence {
    TEXT
  }

# Aliasing of anchors (see Section 10.2)
x_anchor-alias =
  element x:anchor-alias {
    attribute value { TEXT },
    empty
  }

# Including Author information
# (experimental)
x_include-author =
  element x:include-author {
    attribute target { xsd:IDREF }
  }

# Setting section numbers for internally generated sections
# (experimental)
x_assign-section-number =
  element x:assign-section-number {
    attribute builtin-target { "authors" },
    attribute number { TEXT },
    empty
  }

# Bottom line of box drawing (see Section 10.4)
x_bb =
  element x:bb {
    (TEXT
      | iref
      | xref
      | x_bb
      | x_bc
      | x_bt
      | x_ref)*
  }

# Center line of box drawing (see Section 10.5)
x_bc =
  element x:bc {
    (TEXT
      | iref
      | spanx
      | xref
      | x_bb
      | x_bc
      | x_bt
      | x_ref)*
  }

# BCP14/RFC2119 keywords (see Section 10.3)
x_bcp14 =
  element x:bcp14 {
    "MAY"
    | "MUST"
    | "MUST NOT"
    | "NOT RECOMMENDED"
    | "OPTIONAL"
    | "RECOMMENDED"
    | "REQUIRED"
    | "SHALL"
    | "SHALL NOT"
    | "SHOULD"
    | "SHOULD NOT"
  }

# Blockquote (see Section 10.6)
x_blockquote =
  element x:blockquote {
    attribute cite { URI }?,
    t+
  }

# Boilerplate (see Section 10.6)
x_boilerplate =
  element x:boilerplate {
    section+
  }

# Top line of box drawing (see Section 10.8)
x_bt =
  element x:bt {
    (TEXT
      | iref
      | xref
      | x_bb
      | x_bc
      | x_bt
      | x_ref)*
  }

# Definition (see Section 10.9)
x_dfn =
  element x:dfn {
    attribute anchor { xsd:ID }?,
    (TEXT
      | iref)*
  }

# Heading (see Section 10.10)
x_h =
  element x:h {
    TEXT
  }

# Heading (see Section 10.11)
x_highlight =
  element x:highlight {
    TEXT
  }

# Length Measurement (see Section 10.12)
x_length-of =
  element x:length-of {
    attribute indented { NUMBER }?,
    attribute target { xsd:IDREF },
    empty
  }

# Link (see Section 10.13)
x_link =
  element x:link {
    attribute href { URI },
    attribute title { TEXT }?,
    attribute rel { TEXT },
    empty
  }

# Extended list item (see Section 10.14)
x_lt =
  element x:lt {
    attribute anchor { xsd:ID }?,
    attribute hangText { TEXT }?,
    t+
  }

# Note (see Section 10.15)
x_note =
  element x:note {
    t+
  }

# Signal XML content (see Section 10.16)
x_parse-xml =
  element x:parse-xml {
    (TEXT
      | xref)*
  }

# Inline prose in a reference (see Section 10.17)
x_prose =
  element x:prose {
    TEXT
  }

# Inline quote (see Section 10.18)
x_q =
  element x:q {
    TEXT
  }

# Anchor reference (see Section 10.19)
x_ref =
  element x:ref {
    attribute anchor { xsd:ID }?,
    TEXT
  }

# source information (see Section 10.20)
x_source =
  element x:source {
    attribute basename { ATEXT }?,
    attribute href { URI },
    empty
  }

# superscript (see Section 10.21)
x_sup =
  element x:sup {
    TEXT
  }

# Inline Span
x_span =
  element x:span {
    attribute anchor { xsd:ID }?,
    (TEXT
      | x_parse-xml)*
  }

# Nop (for alignment in source)
x_x =
  element x:x {
    empty
  }

# Embed RDF statements
rdf_Description =
  element rdf:Description {
    rdf_content
  }

rdf_content =
  ( TEXT | element * { rdf_content })*

B. Implementation Notes

B.1 Recognized type attributes for <artwork> element

Specific values in the <artwork> element's "type" attribute are recognized and cause a different visual style to be used:

Media Type | Comment
abnf | ABNF as per [RFC5234]
abnf2616 | ABNF as per [RFC2616], Section 2.1
application/relax-ng-compact-syntax | Relax NG Compact Syntax as per [RNC]
application/xml-dtd | XML DTD
message/http; msgtype="request" | HTTP message, as per [RFC2616], Section 19.1
message/http; msgtype="response" | HTTP message, as per [RFC2616], Section 19.1

C. Examples

C.1 Using the 'Internal Subset'

The prolog of the XML document can both be used to refer to an external DTD, and also to define internal entities (Section 2.8 of [XML]):

<?xml version="1.0"?>
<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [

  <!-- use "&MAY;" for a BCP 14 "MAY", see Section 10.3 -->
  <!ENTITY MAY
  "<bcp14 xmlns='http://purl.org/net/xml2rfc/ext'>MAY</bcp14>">

  <!-- re-declare "&nbsp;" as code point 160 (non-breaking space) -->
  <!-- you may need this for UAs that do not read external DTDs -->
  <!ENTITY nbsp
  "&#160;">

  <!-- allow later RFC2616 reference using "&rfc2616;" -->
  <!ENTITY rfc2616 PUBLIC
  "http://xml.resource.org/public/rfc/bibxml/reference.RFC.2616.xml">

]>

Note: including entities from a remote site will not work in Firefox, see <https://bugzilla.mozilla.org/show_bug.cgi?id=22942>.

C.2 Customization

The XSLT code can be customized by creating a custom XSLT file that uses <xsl:import> to include the original code, and just overrides particular rules.

For instance, the code below overrides several attributes in rfc2629toFO.xslt, changing the color, spacing and font family for headers.

<xsl:transform xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
               version="1.0">

  <xsl:import href="rfc2629toFO.xslt"/>

  <xsl:attribute-set name="h1">
    <xsl:attribute name="color">darkblue</xsl:attribute>
    <xsl:attribute name="font-family">sans-serif</xsl:attribute>
    <xsl:attribute name="space-before">24pt</xsl:attribute>
  </xsl:attribute-set>

  <xsl:attribute-set name="h2">
    <xsl:attribute name="color">darkblue</xsl:attribute>
    <xsl:attribute name="font-family">sans-serif</xsl:attribute>
    <xsl:attribute name="space-before">18pt</xsl:attribute>
    <xsl:attribute name="space-after">3pt</xsl:attribute>
  </xsl:attribute-set>

  <xsl:attribute-set name="h3">
    <xsl:attribute name="color">darkblue</xsl:attribute>
    <xsl:attribute name="font-family">sans-serif</xsl:attribute>
    <xsl:attribute name="space-before">16pt</xsl:attribute>
    <xsl:attribute name="space-after">2pt</xsl:attribute>
  </xsl:attribute-set>

</xsl:transform>

Note: the name for the attribute sets may change in the future as more working is done with respect to customizability. In any case, overriding the settings in a separate file will be easier to maintain. Please contact the author if you find yourself trying to override style definitions that currently do not use attribute sets.

Note: the CSS style information used in rfc2629.xslt can be overriden in a similar (but less granular) way: just overwrite the template called "insertCss". As for XSL-FO, the class names may change in future.

D. The /rfc/@ipr Attribute

The ipr specifies what kind of text is generated for the "Status Of This Memo" and "Copyright Notice" sections on the front page. When submitting an Internet Draft, the "boilerplate" is checked by "Idnits" (<http://tools.ietf.org/tools/idnits/>) for compliance with the current Intellectual Property rules, and thus it's important to set the correct value.

As of the time of this writing, the attribute value can take a long list of values. As frequently, this is not the result of a grand plan, but simply for historic reasons. Of these values, only a few are currently in use; all others are supported by the various tools for backwards compatibility with old source files.

Note: some variations of the boilerplate are selected based on the document's date; therefore it is important to specify the "year", "month" and "date" attributes when archiving the XML source of an Internet Draft on the day of submission.

Disclaimer: THIS ONLY PROVIDES IMPLEMENTATION INFORMATION. IF YOU NEED LEGAL ADVICE, PLEASE CONTACT A LAWYER. For further information, refer to <http://trustee.ietf.org/docs/IETF-Copyright-FAQ.pdf>.

D.1 Current Values: '*trust200902'

The name for these values refers to the "TLP" ("IETF TRUST Legal Provisions Relating to IETF Documents"), on effect February 15, 2009 (see <http://trustee.ietf.org/license-info/archive/IETF-Trust-License-Policy-20090215.pdf>). Updates to this document were published on September 12, 2009 (TLP 3.0, <http://trustee.ietf.org/license-info/archive/IETF-Trust-License-Policy-20090912.pdf>) and on December 28, 2009 (TLP 4.0, <http://trustee.ietf.org/license-info/archive/IETF-Trust-License-Policy-20091228.pdf>), modifying the license for code components. The actual text is located in Section 6 ("Text To Be Included in IETF Documents") of these documents.

The tools will automatically produce the "right" text depending on the document's date information (see above):

TLP | URI | starting with publication date
3.0 | <http://trustee.ietf.org/license-info/archive/IETF-Trust-License-Policy-20090912.pdf> | 2009-11-01
4.0 | <http://trustee.ietf.org/license-info/archive/IETF-Trust-License-Policy-20091228.pdf> | 2010-04-01

D.1.1 trust200902

This should be the default, unless one of the more specific '*trust200902' values is a better fit. It produces the text in Sections 6.a and 6.b of the TLP.

D.1.2 noModificationTrust200902

This produces the additional text from Section 6.c.i of the TLP:

This document may not be modified, and derivative works of it may not be created, except to format it for publication as an RFC or to translate it into languages other than English.

D.1.3 noDerivativesTrust200902

This produces the additional text from Section 6.c.ii of the TLP:

This document may not be modified, and derivative works of it may not be created, and it may not be published except as an Internet-Draft.

D.1.4 pre5378Trust200902

This produces the additional text from Section 6.c.iii of the TLP, frequently called the "pre-5378 escape clause":

This document may contain material from IETF Documents or IETF Contributions published or made publicly available before November 10, 2008. The person(s) controlling the copyright in some of this material may not have granted the IETF Trust the right to allow modifications of such material outside the IETF Standards Process. Without obtaining an adequate license from the person(s) controlling the copyright in such materials, this document may not be modified outside the IETF Standards Process, and derivative works of it may not be created outside the IETF Standards Process, except to format it for publication as an RFC or to translate it into languages other than English.

See Section 4 of <http://trustee.ietf.org/docs/IETF-Copyright-FAQ.pdf> for further information about when to use this value.

Note: this text appears under "Copyright Notice", unless the document was published before November 2009, in which case it appears under "Status Of This Memo".

D.2 Historic Values

D.2.1 Historic Values: '*trust200811'

The attribute values "trust200811", "noModificationTrust200811" and "noDerivativesTrust200811" are similar to their "trust200902" counterparts, except that they use text specified in <http://trustee.ietf.org/license-info/archive/IETF-Trust-License-Policy_11-10-08.pdf>.

D.2.2 Historic Values: '*3978'

The attribute values "full3978", "noModification3978" and "noDerivatives3978" are similar to their counterparts above, except that they use text specified in RFC 3978 (March 2005).

D.2.3 Historic Values: '*3667'

The attribute values "full3667", "noModification3667" and "noDerivatives3667" are similar to their counterparts above, except that they use text specified in RFC 3667 (February 2004).

D.2.4 Historic Values: '*2026'

The attribute values "full2026" and "noDerivativeWorks2026" are similar to their counterparts above, except that they use text specified in RFC 2026 (October 1996).

The special value "none" was also used back then, and denied the IETF any rights beyond publication as Internet Draft.

E. License

Copyright (c) 2006-2010, Julian Reschke (julian.reschke@greenbytes.de)

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of Julian Reschke nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

F. Change Logs

F.1 Package

2006-01-01
Switch to BSD License.
2007-01-12
Update to xml2rfc v1.33pre2.
2007-03-31
Update to xml2rfc v1.33pre3.
2007-05-01
Add XSLT test cases.
2008-07-18
Experimental support for inlined rdf:Description elements (ignored by the formatter, extracted by rfc2629grddl).
2008-12-04
Update to xml2rfc v1.34pre2.
2009-02-24
Experimental support for February 2009 boilerplate changes, and for the x:boilerplate element.
2009-07-08
Support new boilerplate ordering in RFCs published since July 2009. Fix problems with one-column text tables.
2009-07-19
When possible, calculate the actual Expiry date for Internet Drafts (full date must be available).
2009-08-01
For '$xml2rfc-ext-authors-section='end'", move the index in front of the authors section.
2009-08-04
Consider /rfc/@ipr="pre5378Trust200902" when producing RFCs, not IDs.
2009-08-29
Support alignment for artwork containing images (as opposed to, well, artwork).
2009-09-01
Allow xref in cref (as extension).
2009-09-14
Refactor handling of processing instructions.
2009-09-24
Fix typo in Status Of This Memo, present since November 2008. Fix formatting of iprExtract attribute. Starting with Internet Draft publication dates after 2009-11-30: use new Trust Legal Provisions text; for Internet Drafts: move Abstract up, and move "pre5378" escape clause to the Copyright Notice. Add support for refparent PI. For RFCs: use new TLP text as of September 2009. Incorporate xml2rfc v1.34pre4.
2009-10-06
Starting with Internet Draft publication dates after 2009-10-31: use new Trust Legal Provisions text; for Internet Drafts: move Abstract up, and move "pre5378" escape clause to the Copyright Notice. Incorporate xml2rfc v1.34pre5.
2009-10-27
Upgrade to xml2rfc v1.34.
2010-01-08
For RFC generation (not IDs), experimentally support RFC 5741 headers and boilerplate and Trust Legal Provisions 4.0.
2010-03-31
Upgrade to xml2rfc v1.35.
2010-06-27
Be consistent with xml2rfc.tcl in formatting initials (truncate after the first); see <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/10>.
2010-08-31
Experimental support for prose in references.

F.2 amazon-asin.xslt

2003-11-16
Initial release.
2005-04-02
Fix two DTD issues.

F.3 check-references.xslt

2003-11-16
Initial release.
2004-05-11
Add document status; print references type.
2005-01-01
Add experimental check for ID status.
2005-04-01
Add fixes from Bill Fenner.
2005-12-03
Add checks against local copy of <http://www.w3.org/2002/01/tr-automation/tr.rdf>.
2006-07-22
Add checks for standards levels.
2006-08-06
"check-ietf-references.xslt" replaced by "check-references.xslt".
2007-01-04
Use information online at <http://tools.ietf.org/> to retrieve Internet-Draft status information.
2007-06-16
Fix bug looking up ref type when inside change markup.
2008-06-14
Enhance output when draft was updated, and then published as RFC.
2008-07-12
Add XSLT2-based link target checking.
2008-08-10
Change keywords for "intended-level" to proposed/draft/internet, optionally extract intended level from /rfc/@x:maturity-level attribute.

F.4 gen-reference-graph.xslt

2006-09-03
New.
2007-06-07
Use Carlisle method to define exslt:node-set in msxsml (which means that the stylesheet can now be used with MSXML as well).
2007-10-15
Use W3C data from tr.rdf as well (experimental).

F.5 rfc2629.xslt

2001-03-28
Code rearranged, generate numbered section anchors for paragraphs (t) as well. Fixes in index handling.
2001-04-12
Moved HTML output into XHTML namespace.
2001-10-02
Fixed default location for RFCs and numbering of section references. Support ?rfc editing processing instruction.
2001-10-07
Made telephone number links active.
2001-10-08
Support for vspace element.
2001-10-09
Experimental support for rfc-issue PI.
2001-11-11
Support rfc private PI. Removed bogus code reporting the WG in the header.
2001-11-11
Support rfc private PI. Removed bogus code reporting the WG in the header.
2001-12-17
Support title attribute on references element
2002-01-05
Support for list/@style="@format"
2002-01-09
Display "closed" RFC issues as deleted
2002-01-14
Experimentally and optionally parse XML encountered in artwork elements (requires MSXSL).
2002-01-27
Some cleanup. Moved RFC issues from PIs into namespaced elements.
2002-01-29
Added support for sortrefs PI. Added support for figure names.
2002-02-07
Highlight parts of artwork which are too wide (72 characters).
2002-02-12
Code rearrangement for static texts. Fixes for section numbering. TOC generation rewritten.
2002-02-15
Support for irefs in sections; support iref @primary=true
2002-03-03
Moved anchor prefix into a constant. Added sanity checks on user anchor names.
2002-03-23
Bugfix in detection of matching org names when creating the header. Fixed sorting in subitems.
2002-04-02
Fix TOC link HTML generation when no TOC is generated (created broken HTML table code).
2002-04-03
Made rendering of references more tolerant re: missing parts.
2002-04-08
Fixed reference numbering when references are split into separate sections.
2002-04-16
Fix default namespace (shouldn't be set for HTML output method).
2002-04-19
Lowercase internal CSS selectors for Mozilla compliance. Do not put TOC into ul element.
2002-04-21
Make numbered list inside numbered lists use alphanumeric numbering.
2002-05-05
Updated issue/editing support.
2002-05-15
Bugfix for section numbering after introduction of ed:replace
2002-06-21
When producing private documents, do not include document status, copyright etc.
2002-07-08
Fix xrefs to Appendices.
2002-07-19
Make artwork lightyellow for easier reading. (fielding)
2002-10-09
Translate references title to anchor name to avoid non-uri characters. (fielding)
2002-10-13
Support for tocdepth PI.
2002-11-03
Added temporariry workaround for Mozilla/Transformiix result tree fragment problem. (search for 'http://bugzilla.mozilla.org/show_bug.cgi?id=143668')
2002-12-25
xref code: attempt to uppercase "section" and "appendix" when at the start of a sentence.
2003-02-02
fixed code for vspace blankLines="0", enhanced display for list with "format" style, got rid of HTML blockquote elements, added support for "hangIndent"
2003-04-10
experimental support for appendix and spanx elements
2003-04-19
fixed counting of list numbers in "format %" styles (one counter per unique format string). Added more spanx styles.
2003-05-02
experimental texttable support
2003-05-02
Make mailto links optional (default = none) (jre: default and PI name changed) (fielding)
2003-05-04
experimental support for HTML link elements; fix default for table header alignment default
2003-05-06
support for "background" PI.
2003-05-11
change %c format to lowercase alphabetic. add support for keyword elements (generate META tag). fix various HTML conformance problems. added experimental support for role attribute. do not number paragraphs in unnumbered sections. update boilerplate texts. support for "iprnotified" PI. bugfix list numbering. strip whitespace when building tel: URIs.
2003-05-12
more conformance fixes (layout moved into CSS, move lists and figures out of para content, do not use tables for list formatting)
2003-05-13
add DC.Creator meta tag, refactoring
2003-05-16
put nbsps between "section" and section number (xref).
2003-05-18
author summary: add missing comma.
2003-06-06
fix index generation bug (transposed characters in key generation). Enhance sentence start detection (xref starting a section was using lowercase "section").
2003-06-22
exp. support for xref/@format. Add missing support for eref w/o content. exp. support for annotations in reference elements. Code cleanup reference table formatting.
2003-07-09
Another fix for DC.Creator meta tag creation based on RFC2731
2003-07-24
Fix namespace name for DC.Creator.
2003-08-06
Cleanup node-set support (only use exslt (saxon, xalan, libxslt) extension functions; remove Transformix workarounds that stopped to work in Moz 1.4)
2003-08-09
Generate HTML lang tag.
2003-08-10
Map spanx/verb to HTML "samp" element. Fix author name display in references (reverse surname/initials for last author), add "Ed.". Fix internal bookmark generation.
2003-08-17
Add DCMI dates, identifiers and abstract. Add PI to suppress DCMI generation. Do not add TOC entry to Copyright Statement when there is none. Align RFC2629 PI names and parameter names. Change style for inline URIs generated by eref. Add header and footer support. Enhance CSS paging properties. Support topblock PI. Added hooks for proper XHTML generation through separate XSLT. Enhance warning and error messages. Add support for artwork image display. Table formatting fixes (borders, thead continuation).
2003-08-18
Add workaround for MSXML4 node-set and Mozilla node-set issues (fallback just displays are warning).
2003-10-06
Add workaround for broken pre/ins handling in Mozilla (see <http://bugzilla.mozilla.org/show_bug.cgi?id=204401>). Make use of cite attribute on ed:replace. CSS cleanup.
2003-10-08
Fix minor issue detecting the same org for the header (caused by IE's non-standard whitespace handling). Fix default handling for /rfc/@category.
2003-11-09
Inherit ed:entered-by from ancestor elements. Change CSS color for inserted text to green. Generate issues-list anchor. Do not complain about missing targets when the xref element is below ed:del. Remove code that attempted to distinguish section/Section when producing links - always use uppercase. Fix date rendering for issue resolutions.
2003-11-29
Fix color values for table backgrounds for issue rendering. Change rendering of issue links to use inline-styles. Add colored issue markers to issues.
2003-12-13
Fix inheritance of ed:entered-by attribute. Display note elements inside change tracking as well.
2004-01-18
When PI compact = 'yes', make most CSS print page breaks conditional.
2004-02-20
Support for RFC3667 IPR changes (xml2rfc 1.22); see <http://lists.xml.resource.org/pipermail/xml2rfc/2004-February/001088.html>.
2004-03-11
Add "(if approved)" to "updates" and "obsoletes" unless the document has an RFC number.
2004-04-01
Fix RFC3667 output, see <http://lists.xml.resource.org/pipermail/xml2rfc/2004-April/001208.html>.
2004-04-04
Add support for section/top attribute. Move references into plain section container.
2004-04-06
Do not emit identical para anchors for deleted content.
2004-04-14
Fix references TOC generation when there are no references.
2004-04-24
Fix RFC3667 output, see <http://xml.resource.org/pipermail/xml2rfc/2004-April/001246.html>.
2004-05-09
Add custom support for generating compound index documents. Add anchors for each Index letter. Add experimental cref support. Fix conditional page breaks before References section.
2004-05-16
Refactor external index generation.
2004-05-20
Rewrite anchor generation for comments.
2004-05-22
Enhance issues rendering (add links to changes).
2004-05-30
Allow single quote as delimiter in processing instructions as well. Move block-level issue pointers to floats. Disable issue pointers for print media. Add "purple numbers". Add hrefs to section headings. Add non-printing index key letter list to start of index.
2004-06-01
Use &#xb6; instead of # for PNs.
2004-07-18
Add support for list style=letters (thanks Roy F.). Make PNs optional; add new PI.
2004-09-05
Fix index links into unnumbered sections. Bring IPR boilerplate in-line with xml2rfc 1.25. Add experimental CSS3 paged media support. Various HTML fixes.
2004-09-21
Enhance checking of artwork width.
2004-09-26
Add check for unused references. Uppercase letters in list style letters when nested into another list.
2004-10-10
Fix internal change track pointers.
2004-11-01
Allow change tracking on references (as a whole). Rewrite artwork handling so that it allows change tracking inside artwork. Also allow a subset of text markup inside artwork, such as xrefs (note this requires post-processing the source to make it compliant to RFC2629bis).
2004-11-03
Enhanced placement of iref anchors.
2004-11-06
Index: display irefs that appeared (with primary=true) inside artwork elements in a monospaced font.
2004-11-14
Add special code so that changes in section titles can be change-tracked.
2005-01-14
Bugfixes for HtmlToXhtml converter.
2005-01-22
Enhance generation of HTML h* elements (for Mozilla Outliner).
2005-01-31
Put vertical space around top-level TOC entries in TOC. Switch to pt-based CSS. Re-arrange top section. Make hr elements reflect new-page settings in TXT output (compact-PI). Fix page number in footer (CSS print) and add some more experimental support for paged media (tested with Prince 4.1 alpha). Rewrite TOC and Index generation to generate HTML lists. Cleanup id generation for paragraphs. Reduce whitespace in output. Fix vspace implementation. Use right/left dqoutes and copyright sign where appropriate.
2005-02-04
Add <link> element to references section. Fix newly introduced bug in references processing.
2005-02-05
Integrate various fixes/enhancements by Roy Fielding: spelling of "Authors' Addresses", comma setting in references, position of "Authors" section, optionally place authors addresses at end (PI), trailing dots in section numbers, switch to verdana default font in CSS. Add experimental support for centered artwork.
2005-02-09
Fixes in spacing and links of references section titles. Enhance sorting in references when change tracking is in place. Re-add figure centering support. Add missing 2nd part of "Author's Adresses" fix.
2005-02-25
Align section number format with xml2rfc1.29.
2005-03-28
Get rid of table elements in Author's section. Add experimental hCard (<http://developers.technorati.com/wiki/hCard>) support.
2005-04-03
Add RFC3978-style IPR statement support. (fenner@research.att.com)
2005-04-11
Cleanup author display. hCard related fixes.
2005-05-07
Minor fixes to allow change tracking in doc title. Add experimental support for table border styles. CSS cleanup.
2005-06-18
Implement missing support for references to texttables.
2005-09-25
Use (-moz-)column-count when printing the index.
2005-10-04
Report missing element templates with xsl:message.
2005-10-15
Process t/@anchor.
2005-10-23
More workarounds for Mozilla's broken del/ins handling (this time for figures).
2005-10-27
lowercase hCard class names
2005-11-22
Enhance diagnostics for XML-in-artwork extension
2005-11-26
Fix formatting of section numbers for sections inserted into <back>.
2005-12-12
Fix some validity problems when change tracking occured inside lists.
2005-12-18
Add change tracking inside the index.
2006-02-04
Add prev/next links to highlighted changes (change tracking extension).
2006-02-10
Catch errors instantiating MSXML component.
2006-02-11
References: add "work in progress" for Internet Drafts.
2006-02-27
Fix front matter (lowercase Internet-Draft, say "Intended status" for non-RFC documents). Start work on experimental extension for simplified internal links.
2006-03-19
Tweaks to IESG Copyright stuff; support submissionType attribute. Fix duplicate reference anchors in HTML output. Reduce HTML Tidy warnings. Fix reference to normative ASCII version (now requires trailing ".txt"). Tweaks to hCard generation. Started to move non-issue-tracking extensions into namespace "http://purl.org/net/xml2rfc/ext".
2006-03-27
Moved "simple reference" extension into namespace "http://purl.org/net/xml2rfc/ext" and add documentation. HTML conformance enhancements.
2006-04-02
Cleanup special code for automated XHTML XSLT generation.
2006-04-21
Generate <CITE> elements where appropiate. Introduce x:blockquote, x:dfn, x:h and x:q elements.
2006-05-06
Introduce x:bcp14 element.
2006-05-14
Fix content model for x:blockquote.
2006-06-18
Add box drawing support (x:bt, x:bc, x:bb).
2006-06-20
HTML validity fixes (legal chars in anchors in index).
2006-06-24
Reduce leading empty lines in artwork. Move <dt> style info into CSS.
2006-07-14
Fix rendering of multiple street address entries (missing line break).
2006-07-24
Add extension for deep linking into RFCs, do not generate empty list items in TOC output, avoid empty <dt> elements for list items without hangText attribute.
2006-08-01
Allow @anchor on more elements; start work on Relax NG grammar for extensions. Reduce generated style elements (use CSS classes instead). Consistently use "id" instead of "name". Change default target for RFC links to "http://tools.ietf.org/html/rfcNNNN".
2006-08-06
Include appendices defined in <appendix> elements in TOC (please consider them deprecated anyhow!). Generate links to "http://tools.ietf.org/html/draft-*" for Internet Drafts. Replace x:frag by x:rel, allowing any kind of relative reference instead of just fragments.
2006-08-30
Reduce textual differences between HTML output and what xml2rfc produces in TXT output mode (section refs/reference targets). Add small workaround for Opera 9.0.1's problem with node-set().
2006-10-29
Fix problem generating internal links to change markup within references section. Enhancements when generating numbered references for deleted references. Allow inclusion of references into the index (through include-references-in-index extension). Fix a bug that caused the newer version of the IETF boilerplate to be produced rather than the pre-RFC3667 one. Update to RFC4287 boilerplate.
2006-11-11
Add extension attribute x:for-anchor to <iref> handling.
2006-11-26
Experimental (and limited) support for <x:lt>.
2006-12-04
Fix bugs in processing documents that have both the ipr and the number attribute set on the rfc root element. Add support for x:fmt='none' on xrefs. Add different pre style based on artwork type attributes (experimental).
2006-12-13
Add x:fmt='anchor' for xref elements.
2007-01-07
Fix root template for compatibility for the exslt:node-set implementation in Firefox3.
2007-01-29
Avoid empty table entry in front matter when organization is not specified for an author.
2007-02-10
Allow change tracking in table rows.
2007-03-09
Add hcard profile URI (<http://www.w3.org/2006/03/hcard>) to head element. Add warning for misplaced <t> elements (after section).
2007-03-21
Fix internal linking from reference entries in index for some xref types. Minor CSS tweaks contributed by MTR. Allow turning on text justification through a PI. Improve iref anchor generation to generate less instable anchors.
2007-03-28
Fixes for numbering of ed:inserted references sections.
2007-05-04
Do not generate anchors for edits in deleted sections. Enhance HTML conformance.
2007-05-19
Enhance diagnostics when using Saxon (needs Saxon's "-l" command line parameter to keep line number information). Add warning when symref PI is missing (default will change in the future). Add support for overriding computed section numbers (when formatting historic documents).
2007-06-07
Change default for symrefs PI to "yes" (see change in xml2rfc 1.33pre4). Warn about docName attributes that appear to contain a file extension.
2007-06-26
Workaround author/@initials values without trailing dot, as in xml2rfc.tcl.
2007-07-14
Enhance index generation for references that use @x:sec attribute.
2007-09-09
Fix: sortrefs is a nop when symrefs=no.
2007-10-17
Work in progress: add support for referencing sections in sibling documents by anchor name.
2007-10-17
Work in progress (continued): support for referencing sections in sibling documents by anchor name.
2007-12-31
Emit warning when updating/obsoleting stuff that's not referenced.
2008-02-03
Support xml2rfc-1.33pre5's suppress-title attribute on texttable and figure.
2008-02-06
Extension: allow <eref> below <cref>.
2008-02-17
Extensions: add x:span and x:length-of.
2008-02-20
Add new RFC boilerplate (as changed in 2007-08).
2008-02-27
Improve diagnostics for artwork width problems; add defaulting of publication dates (requires XSLT processor supporting exslt:date, or msxml).
2008-02-29
Enhance CSS for link elements in the front header, update rules for generating "Acknowledgment" statement.
2008-03-01
Use line numbers in diagnostics in Saxon8/9 as well.
2008-03-02
Fix a bug in the logic choosing the boilerplate, resulting in obsolete text being inserted into IDs.
2008-04-01
Add support for superscript element.
2008-06-28
Add sanity checks for email addresses, allow multiple email elements.
2008-07-06
Add x:abnf-char-sequence.
2008-08-21
Add x:note.
2008-09-06
Add experimental support for SVG images.
2008-09-17
Add experimental support for x:author. Fix xref/@format=none.
2008-10-10
Fix a huge bug, causing text content after an XML comment to be ignored.
2009-02-24
Use table/caption when needed.
2009-03-07
Fix bug that caused text to disappear in the output in presence of processing instructions.
2009-03-12
Make inlined comments bookmarkable.
2009-04-09
Upgrade to DC-HTML from RFC 2731 (affects head/@profile).
2009-07-08
Remove table/@summary in output; the value getting inserted was just repeating stuff that appeared in the preamble.
2009-08-01
Implement table alignment (HTML output only for now).
2009-08-18
Replicate Dublin Core "abstract" metadata into meta/@name=description (search engines do use it).
2009-09-02
Fix default/left alignment of table columns, remove silly table summmary attributes.
2009-09-24
Support double-sided layout using CSS page:left/right selectors.
2009-11-27
Generate unordered lists instead of broken definition lists for list style empty.

F.6 rfc2629toFO.xslt

2003-11-16
Initial release.
2003-11-29
Enhance handling of unknown list styles.
2004-04-04
Update reference section handling.
2004-04-17
Use XSL-WD-1.1-style fo:bookmark and index handling and add postprocessors for existing implementations. Unify PDF info generation by using XEP (postprocessors) will convert.
2004-04-20
Add experimental cref support.
2004-06-14
Set correct index-item defaults.
2004-07-18
Add list style=letters.
2004-09-03
Make URLs in text break where they are allowed to break by inserting zero-width spaces.
2004-09-26
Fix letter-style inside nested lists.
2004-10-31
Update handling of artwork.
2004-11-13
Fix handling of references inside ed:* markup. Fix whitespace handling in artwork.
2004-11-27
Irefs in artwork generate monospaced entries in index.
2005-01-31
Fix TOC generation that was broken after changes in main XSLT.
2005-02-05
Bring in sync with cosmetic changes in rfc2629.xslt.
2005-05-07
Minor fix for change tracking in document title. Support for table styles.
2005-06-18
Fix references to tables.
2005-10-15
Process t/@anchor.
2006-02-11
References: add "work in progress" for Internet Drafts.
2006-06-02
Use XSL 1.1 WD Feb 2006.
2007-03-21
Support optional text justification.
2007-05-19
Various improvements in spacing; also allow overriding the automatic list indentation via list/x:indent.
2009-04-08
Fix spacing in headers; add support for formatting for double-sided printing.
2009-08-01
Remove surplus empty pages when not generating double-sided output.

F.7 xsl11toAn.xslt

2004-05-17
Initial release.
2006-06-02
Use XSL 1.1 WD Feb 2006.

F.8 xsl11toFop.xslt

2010-08-25
Switch to Apache FOP 1.0.
2009-09-12
Support for FOP 0.20.5 and FOP 0.93 removed. Please use FOP 0.95.
2008-03-15
Add a workaround to the fo:inline workaround (sigh).

F.9 xsl11toXep.xslt

2004-05-17
Initial release.
2004-09-04
Fix xep:index-item attributes.
2006-06-02
Use XSL 1.1 WD Feb 2006.

Index

A B C D E F G H I J K L M N O P Q R S T X

  • A
    • abnf-char-sequence Extension Element 10.1, A
    • allow-markup-in-artwork PI pseudo-attribute 3.3
    • alternate HTML LINK element 6.2
    • anchor-alias Extension Element 10.2, A
    • Anchors
      • rfc.abstract 4
      • rfc.authors 4
      • rfc.copyright 4
      • rfc.copyrightnotice 4
      • rfc.figure.n 4, 4
      • rfc.figure.u.n 4, 4
      • rfc.index 4
      • rfc.ipr 4
      • rfc.iref.n 4
      • rfc.note.n 4
      • rfc.references 4, 4
      • rfc.section.n 4
      • rfc.section.n.p.m 4
      • rfc.status 4
      • rfc.toc 4
      • rfc.xref.name.n 4
    • AntennaHouse XSL Formatter 9.1
    • Apache FOP 9.1
    • appendix HTML LINK element 6.2
    • assign-section-number Extension Element A
    • author HTML LINK element 6.2
    • authors-section PI pseudo-attribute 3.3
  • B
    • background PI pseudo-attribute 3.1
    • bb Extension Element 10.4, A
    • bc Extension Element 10.5, A
    • bcp14 Extension Element 10.3, A
    • BCP97 11.1, 12
    • blockquote Extension Element 10.6, A
    • boilerplate Extension Element 10.7, A
    • bt Extension Element 10.8, A
  • C
    • chapter HTML LINK element 6.2
    • CHM format 8
    • comments PI pseudo-attribute 3.1
    • compact PI pseudo-attribute 3.1
    • contents HTML LINK element 6.2
    • copyright HTML LINK element 6.2
    • Creator DCMI property 6.4
  • D
    • Date.Issued DCMI property 6.4
    • DC-HTML 6.4, 12
    • DCMI properties
      • Creator 6.4
      • Date.Issued 6.4
      • Description.Abstract 6.4
      • Identifier 6.4
      • isPartOf 6.4
      • Relation.Replaces 6.4
    • Description.Abstract DCMI property 6.4
    • dfn Extension Element 10.9, A
    • duplex PI pseudo-attribute 3.3
  • E
    • editing PI pseudo-attribute 3.1
    • Extension Elements
      • abnf-char-sequence 10.1, A
      • anchor-alias 10.2, A
      • assign-section-number A
      • bb 10.4, A
      • bc 10.5, A
      • bcp14 10.3, A
      • blockquote 10.6, A
      • boilerplate 10.7, A
      • bt 10.8, A
      • dfn 10.9, A
      • h 10.10, A
      • highlight 10.11, A
      • include-author A
      • length-of 10.12, A
      • link 10.13, A
      • lt 10.14, A
      • note 10.15, A
      • parse-xml 10.16, A
      • prose 10.17, A
      • q 10.18, A
      • rdf:Description A
      • ref 10.19, A
      • source 10.20, A
      • span A
      • sup 10.21, A
      • x A
  • F
    • Firefox
      • 1.*/2.* 5.2
      • 3.* 5.2
    • footer PI pseudo-attribute 3.1
  • G
    • generator HTML META element 6.3
    • Google Chrome 5.2
    • Grammar A
  • H
    • h Extension Element 10.10, A
    • header PI pseudo-attribute 3.1
    • highlight Extension Element 10.11, A
    • HTML 6.1, 10.6, 10.9, 10.18, 10.21, 12
    • HTML compliance 6.1
    • HTML LINK elements
      • alternate 6.2
      • appendix 6.2
      • author 6.2
      • chapter 6.2
      • contents 6.2
      • copyright 6.2
      • index 6.2
    • HTML META elements
      • generator 6.3
      • keywords 6.3
  • I
    • Identifier DCMI property 6.4
    • include PI pseudo-attribute 3.2
    • include-author Extension Element A
    • include-references-in-index PI pseudo-attribute 3.3
    • index HTML LINK element 6.2
    • inline PI pseudo-attribute 3.1
    • Internet Explorer 5.5 5.2
    • Internet Explorer 6 5.2
    • Internet Explorer 7 5.2
    • Internet Explorer 8 5.2
    • iprnotified PI pseudo-attribute 3.1
    • isPartOf DCMI property 6.4
  • J
    • justification PI pseudo-attribute 3.3
  • K
    • keywords HTML META element 6.3
  • L
    • length-of Extension Element 10.12, A
    • link Extension Element 10.13, A
    • linkmailto PI pseudo-attribute 3.1
    • lt Extension Element 10.14, A
  • M
    • Microsoft Help 8
    • Mozilla 5.2, 5.2
    • MSXML3 5.1
    • MSXML4 5.1
  • N
    • needLines PI pseudo-attribute 3.2
    • NoScript 5.2
    • note Extension Element 10.15, A
  • O
    • Opera 5.2, 5.2
  • P
    • Parameters
      • xml2rfc-background 3.1
      • xml2rfc-comments 3.1
      • xml2rfc-compact 3.1
      • xml2rfc-editing 3.1
      • xml2rfc-ext-allow-markup-in-artwork 3.3
      • xml2rfc-ext-authors-section 3.3
      • xml2rfc-ext-duplex 3.3
      • xml2rfc-ext-include-references-in-index 3.3
      • xml2rfc-ext-justification 3.3
      • xml2rfc-ext-parse-xml-in-artwork 3.3
      • xml2rfc-ext-sec-no-trailing-dots 3.3
      • xml2rfc-ext-support-rfc2731 3.3
      • xml2rfc-footer 3.1
      • xml2rfc-header 3.1
      • xml2rfc-inline 3.1
      • xml2rfc-iprnotified 3.1
      • xml2rfc-linkmailto 3.1
      • xml2rfc-private 3.1
      • xml2rfc-refparent 3.1
      • xml2rfc-rfcedstyle 3.1
      • xml2rfc-sortrefs 3.1
      • xml2rfc-symrefs 3.1
      • xml2rfc-toc 3.1
      • xml2rfc-tocdepth 3.1
      • xml2rfc-topblock 3.1
    • parse-xml Extension Element 10.16, A
    • parse-xml-in-artwork PI pseudo-attribute 3.3
    • private PI pseudo-attribute 3.1
    • Processing Instruction pseudo attributes
      • allow-markup-in-artwork 3.3
      • authors-section 3.3
      • background 3.1
      • comments 3.1
      • compact 3.1
      • duplex 3.3
      • editing 3.1
      • footer 3.1
      • header 3.1
      • ijustification 3.3
      • include 3.2
      • include-references-in-index 3.3
      • inline 3.1
      • iprnotified 3.1
      • linkmailto 3.1
      • needLines 3.2
      • parse-xml-in-artwork 3.3
      • private 3.1
      • refparent 3.1
      • rfcedstyle 3.1
      • sec-no-trailing-dots 3.3
      • slides 3.2
      • sortrefs 3.1
      • strict 3.2
      • subcompact 3.2
      • support-rfc2731 3.3
      • symrefs 3.1
      • toc 3.1
      • tocdepth 3.1
      • tocindent 3.2
      • tocompact 3.2
      • topblock 3.1
    • prose Extension Element 10.17, A
  • Q
    • q Extension Element 10.18, A
  • R
    • rdf:Description Extension Element A
    • ref Extension Element 10.19, A
    • refparent PI pseudo-attribute 3.1
    • Relation.Replaces DCMI property 6.4
    • RELAX NG Compact Schema A
    • rfc.abstract anchor 4
    • rfc.authors anchor 4
    • rfc.copyright anchor 4
    • rfc.copyrightnotice anchor 4
    • rfc.figure.n anchor 4, 4
    • rfc.figure.u.n anchor 4, 4
    • rfc.index anchor 4
    • rfc.ipr anchor 4
    • rfc.iref.n anchor 4
    • rfc.note.n anchor 4
    • rfc.references anchor 4
    • rfc.references.n anchor 4
    • rfc.section.n anchor 4
    • rfc.section.n.p.m anchor 4
    • rfc.status anchor 4
    • rfc.toc anchor 4
    • rfc.xref.name.n anchor 4
    • RFC2026 10.25, 12
      • Section 4.1 10.25
    • RFC2119 10.3, 10.27, 12
      • Section 5 10.27
    • RFC2616 12, B.1, B.1, B.1
      • Section 2.1 B.1
      • Section 19.1 B.1, B.1
    • RFC2629 1, 12
    • RFC2648 6.4, 12
    • RFC2731 6.4, 12
    • RFC5234 12, B.1
    • rfcedstyle PI pseudo-attribute 3.1
    • RNC 12, A, B.1
  • S
    • Safari 5.2, 5.2
      • 3.* 5.2
    • Saxon 5.1
    • Schema A
    • sec-no-trailing-dots PI pseudo-attribute 3.3
    • slides PI pseudo-attribute 3.2
    • sortrefs PI pseudo-attribute 3.1
    • source Extension Element 10.20, A
    • span Extension Element A
    • strict PI pseudo-attribute 3.2
    • subcompact PI pseudo-attribute 3.2
    • sup Extension Element 10.21, A
    • support-rfc2731 PI pseudo-attribute 3.3
    • symrefs PI pseudo-attribute 3.1
  • T
    • toc PI pseudo-attribute 3.1
    • tocdepth PI pseudo-attribute 3.1
    • tocindent PI pseudo-attribute 3.2
    • tocompact PI pseudo-attribute 3.2
    • topblock PI pseudo-attribute 3.1
  • X
    • x Extension Element A
    • Xalan 5.1
    • XHTML2 10.10, 12
    • XML 12, C.1
      • Section 2.8 C.1
    • xml-stylesheet PI 6
    • xml2rfc-background parameter 3.1
    • xml2rfc-comments parameter 3.1
    • xml2rfc-editing parameter 3.1, 3.1
    • xml2rfc-ext-allow-markup-in-artwork parameter 3.3
    • xml2rfc-ext-authors-section parameter 3.3
    • xml2rfc-ext-duplex 3.3
    • xml2rfc-ext-include-references-in-index parameter 3.3
    • xml2rfc-ext-justification parameter 3.3
    • xml2rfc-ext-parse-xml-in-artwork parameter 3.3
    • xml2rfc-ext-sec-no-trailing-dots parameter 3.3
    • xml2rfc-ext-support-rfc2731 parameter 3.3
    • xml2rfc-footer parameter 3.1
    • xml2rfc-header parameter 3.1
    • xml2rfc-inline parameter 3.1
    • xml2rfc-iprnotified parameter 3.1
    • xml2rfc-linkmailto parameter 3.1
    • xml2rfc-private parameter 3.1
    • xml2rfc-refparent parameter 3.1
    • xml2rfc-rfcedstyle parameter 3.1
    • xml2rfc-sortrefs parameter 3.1
    • xml2rfc-symrefs parameter 3.1
    • xml2rfc-toc parameter 3.1
    • xml2rfc-tocdepth parameter 3.1
    • xml2rfc-topblock parameter 3.1
    • XSL-FO 9.1, 9.1, 12
    • xsltproc 5.1
      • passing parameters 3